Форум Кургана и Курганской области и наших друзей

Зима. Форум Кургана и Курганской области и наших друзей
28 Ноябрь 2020, 15:53:19 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости:
 
   Начало   Помощь Войти Регистрация  
Страниц: 1 2 [3] 4 5 ... 9   Вниз
  Печать  
Автор Тема: Вопросы по 1С  (Прочитано 9253 раз)
0 Пользователей и 1 Гость смотрят эту тему.
AxelAg
Корабельный секретарь
***

Карма: 22
Offline Offline

Пол: Мужской
Сообщений: 180



Награды
« Ответ #30 : 15 Февраль 2011, 19:01:02 »

Тогда посыл:
не верен в принципе.

Посыл верен ибо неизвестно самое главное НАСКОЛЬКО она не типовая Подмигивающий

а то добавили пару отчетов и все, в принципе конфа уже не типовая
Записан

Там где Чероки не пройдет, и даже Хаммер не промчится.
Москвич тихонько проползет и ничего с ним н случится.
ysv45
Гость
« Ответ #31 : 15 Февраль 2011, 19:18:04 »

Посыл верен ибо неизвестно самое главное НАСКОЛЬКО она не типовая Подмигивающий

Ну вот, а что бы узнать надо войти в конфигуратор и тогда возвращаемся к совету:

Надо поступить как программист Улыбка

Посмотреть источник ошибки в отладчике, подумать как исправить - исправить.

Записан
AxelAg
Корабельный секретарь
***

Карма: 22
Offline Offline

Пол: Мужской
Сообщений: 180



Награды
« Ответ #32 : 15 Февраль 2011, 22:21:42 »

Ну вот, а что бы узнать надо войти в конфигуратор и тогда возвращаемся к совету:

Нет, не надо. первые 9 проводок он проводит, не так ли, ошибка на 10-й строке, т.е. у кого-то из сотрудников не все реквизиты по начислению з/п заполнены.

по пунктам надо сделать следующее:
1. Проверить српавочники проводок по статьям затрат
2. Проверить справочник сотрудников (в части операций по начислению зарплаты т.е. у всех ли сотрудников указана статья затрат по заработной плате.)
3. Проверить справочник по приведенной мною выше сцылке ибо с этого года механизм начисления зп в бухучете поменялся.

Как-то так Подмигивающий 99,5% что проблема будет решена.

ЗЫ: у Вас есть 2 мнения, одно Ваше, а другое неправильное Показывает язык
Записан

Там где Чероки не пройдет, и даже Хаммер не промчится.
Москвич тихонько проползет и ничего с ним н случится.
ysv45
Гость
« Ответ #33 : 15 Февраль 2011, 23:13:37 »

Как-то так  99,5% что проблема будет решена.

ЗЫ: у Вас есть 2 мнения, одно Ваше, а другое неправильное Показывает язык

А тут все элементарно - конфигуратор рассудит. Улыбка

И решение 100%.

Записан
AxelAg
Корабельный секретарь
***

Карма: 22
Offline Offline

Пол: Мужской
Сообщений: 180



Награды
« Ответ #34 : 16 Февраль 2011, 01:39:16 »

А тут все элементарно - конфигуратор рассудит. Улыбка

И решение 100%.

Неа, конфигуратор не решит проблему незаполненного справочника, ибо код отрабатывается корректно и ошибка, а если уж следовать букве обработки информации - отсутствие необходимых для расчета данных, не в процедуре обработки проведения, которая и сообщает об отсутствии счетов в проводке, а в процедуре заполнения значений.
Записан

Там где Чероки не пройдет, и даже Хаммер не промчится.
Москвич тихонько проползет и ничего с ним н случится.
ysv45
Гость
« Ответ #35 : 16 Февраль 2011, 01:51:06 »

Неа, конфигуратор не решит проблему незаполненного справочника, ибо код отрабатывается корректно и ошибка, а если уж следовать букве обработки информации - отсутствие необходимых для расчета данных, не в процедуре обработки проведения, которая и сообщает об отсутствии счетов в проводке, а в процедуре заполнения значений.

Конфигуратор "сообщит" обо всем - 100%...
Записан
AxelAg
Корабельный секретарь
***

Карма: 22
Offline Offline

Пол: Мужской
Сообщений: 180



Награды
« Ответ #36 : 16 Февраль 2011, 10:19:05 »

Конфигуратор "сообщит" обо всем - 100%...


В принципе анализируя код можно найти каких именно данных не хватает, но забивать гвозди все-таки удобнее молотком, а не микроскопом.
Записан

Там где Чероки не пройдет, и даже Хаммер не промчится.
Москвич тихонько проползет и ничего с ним н случится.
NikVA
Корабельный секретарь
***

Карма: 2
Offline Offline

Сообщений: 240



Награды
« Ответ #37 : 16 Февраль 2011, 12:49:15 »

В принципе анализируя код можно найти каких именно данных не хватает, но забивать гвозди все-таки удобнее молотком, а не микроскопом.
Я не могу понять спор ты в конфигураторе находишь ошибку если это не заполненное поле или значение идешь и правишь мозг кто это должен заполнять, если проблема в конфиге то правишь. о чем спор Непонимающий? куча букв толку ноль. Тебе нужно решение Непонимающий если нужна помощь то конфиг в студию.
Записан

Опыт и знание растет прямо пропорционально выведенному из строя оборудованию.
ysv45
Гость
« Ответ #38 : 16 Февраль 2011, 13:19:19 »

Я не могу понять спор

Да у нас с AxelAg просто теоретический спор Улыбка Улыбка Улыбка
Записан
AxelAg
Корабельный секретарь
***

Карма: 22
Offline Offline

Пол: Мужской
Сообщений: 180



Награды
« Ответ #39 : 16 Февраль 2011, 16:17:16 »

Я не могу понять спор ты в конфигураторе находишь ошибку если это не заполненное поле или значение идешь и правишь мозг кто это должен заполнять, если проблема в конфиге то правишь. о чем спор Непонимающий? куча букв толку ноль. Тебе нужно решение Непонимающий если нужна помощь то конфиг в студию.

Ошибки в коде конфы нет Подмигивающий потому что до 10-й проводки все отрабатывается нормально, а вот в 10-й проводке по документу незаполнены счета, для анализа какая конкретно часть процедуры эти значения незаполнила предлагается конфигуратором глянуть как именно возникает ошибка, т.е. проанализировать код процедуры, т.к. ошибка возникает в 7000 с чем-то строке анализировать что конкретно и каких данных нехватает = убить очень много времени.

Изначально я предлагаю более короткий путь все-таки проверить правильность заполнения данных в самой конфе, а уж если не поможе тогда искать решение через код.
Записан

Там где Чероки не пройдет, и даже Хаммер не промчится.
Москвич тихонько проползет и ничего с ним н случится.
AxelAg
Корабельный секретарь
***

Карма: 22
Offline Offline

Пол: Мужской
Сообщений: 180



Награды
« Ответ #40 : 16 Февраль 2011, 16:17:43 »

Да у нас с AxelAg просто теоретический спор Улыбка Улыбка Улыбка

Точно Подмигивающий что-то вроде того
Записан

Там где Чероки не пройдет, и даже Хаммер не промчится.
Москвич тихонько проползет и ничего с ним н случится.
NikVA
Корабельный секретарь
***

Карма: 2
Offline Offline

Сообщений: 240



Награды
« Ответ #41 : 17 Февраль 2011, 10:39:34 »

Ошибки в коде конфы нет Подмигивающий потому что до 10-й проводки все отрабатывается нормально, а вот в 10-й проводке по документу незаполнены счета, для анализа какая конкретно часть процедуры эти значения незаполнила предлагается конфигуратором глянуть как именно возникает ошибка, т.е. проанализировать код процедуры, т.к. ошибка возникает в 7000 с чем-то строке анализировать что конкретно и каких данных нехватает = убить очень много времени.

Изначально я предлагаю более короткий путь все-таки проверить правильность заполнения данных в самой конфе, а уж если не поможе тогда искать решение через код.
не знаю но проще все таки в конфиге через отладчик найти. чем по формам лазить ну кране сузить поиск. Удачи вам.
Записан

Опыт и знание растет прямо пропорционально выведенному из строя оборудованию.
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #42 : 18 Февраль 2011, 16:09:57 »

Господа, всё решилось нормально.
Конфа не  много не типовая, просто добавлено несколько реквизитов в справочники, документы и всё заточено для обмена документами с ТИС,
выгрузка-загрузка (банковских выписок, реализаций, списаний и т.д)
Проблема со ставками была в том что я не смотрел в справочник "Тарифы страховых взносов" там значения были не изменены. Изменил, всё решилось.

С документом закрытие месяца поступил следующим образом:
Цитировать
Процедура СформироватьПроводкуСВЗ(Налог, Сотрудник, Сумма, СуммаЕНВД)
   
   Если (Сумма = 0) И (СуммаЕНВД = 0) Тогда
      Возврат;
   КонецЕсли;
   
   Если Сумма <> 0 Тогда
      
      Операция.НоваяПроводка();
      Операция.ПервичныйДокумент  = глПредставлениеПервичногоДокумента(Контекст);

      Если Налог = "ФСС" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.01.3");
         Операция.СодержаниеПроводки = "Начислен взнос в ч. ФСС";
         
      ИначеЕсли Налог = "ПФР_страх" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.01.1");
         Операция.СодержаниеПроводки = "Начислен взнос в ПФР";
         
      ИначеЕсли Налог = "ПФР_нак" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.01.2");
         Операция.СодержаниеПроводки = "Начислен взнос в ПФР";
         
      ИначеЕсли Налог = "ФФОМС" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.01.4");
         Операция.СодержаниеПроводки = "Начислен взнос в ч. ФФОМС";
         
      ИначеЕсли Налог = "ТФОМС" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.01.5");
         Операция.СодержаниеПроводки = "Начислен взнос в ч. ТФОМС";
         
      КонецЕсли;
      
      Операция.Кредит.Субконто(1, Сотрудник);
      Операция.НомерЖурнала = "ЗП";
      
      Операция.Сумма = Сумма;      
   КонецЕсли;
   
   Если СуммаЕНВД <> 0 Тогда
      
      Операция.НоваяПроводка();
      Операция.ПервичныйДокумент  = глПредставлениеПервичногоДокумента(Контекст);

      Если Налог = "ПФР_страх" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.1");
         Операция.СодержаниеПроводки = "Начислен взнос в ПФР по деятельности ЕНВД";
         
      ИначеЕсли Налог = "ПФР_нак" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.2");
         Операция.СодержаниеПроводки = "Начислен взнос в ПФР по деятельности ЕНВД";
         
         
      КонецЕсли;
      
      Операция.Кредит.Субконто(1, Сотрудник);
      Операция.НомерЖурнала = "ЗП";
      
      Операция.Сумма = СуммаЕНВД;  
   
   КонецЕсли;
        Сообщить(" № "+Операция.НомерПроводки()+" Налог "+Налог+" Счет "+Операция.Кредит.Счет+" Сумма "+Сумма+" СуммаЕНВД "+СуммаЕНВД);  //Дописал и определил содержание проводки. Как оказалось до 2011 года в ЕНВД проводки ФСС,ФФОМС,ТФОМС          //небыло , решил следующим образом создал 3 забалансовых счета    и дописал    код   
КонецПроцедуры // СформироватьПроводку()

Цитировать
Если СуммаЕНВД <> 0 Тогда
      
      Операция.НоваяПроводка();
      Операция.ПервичныйДокумент  = глПредставлениеПервичногоДокумента(Контекст);

      Если Налог = "ПФР_страх" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.1");
         Операция.СодержаниеПроводки = "Начислен взнос в ПФР по деятельности ЕНВД";
         
      ИначеЕсли Налог = "ПФР_нак" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.2");
         Операция.СодержаниеПроводки = "Начислен взнос в ПФР по деятельности ЕНВД";
       ИначеЕсли Налог = "ФСС" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.3");
         Операция.СодержаниеПроводки = "Начислен взнос в ч. ФФОМС";   
      ИначеЕсли Налог = "ФФОМС" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.4");
         Операция.СодержаниеПроводки = "Начислен взнос в ч. ФФОМС";
         
      ИначеЕсли Налог = "ТФОМС" Тогда
         Операция.Кредит.Счет = СчетПоКоду("СВЗ.02.5");
         Операция.СодержаниеПроводки = "Начислен взнос в ч. ТФОМС";
         
      КонецЕсли;
      
      Операция.Кредит.Субконто(1, Сотрудник);
      Операция.НомерЖурнала = "ЗП";
      
      Операция.Сумма = СуммаЕНВД;  
   
  КонецЕсли;

« Последнее редактирование: 18 Февраль 2011, 16:15:41 от Vertex » Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
ysv45
Гость
« Ответ #43 : 18 Февраль 2011, 16:40:12 »

Молодец!
Записан
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #44 : 18 Февраль 2011, 16:51:55 »

Молодец!


 Строит глазки   Стараюсь
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
Страниц: 1 2 [3] 4 5 ... 9   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2008, Simple Machines LLC
rss | wap
Valid XHTML 1.0! Valid CSS!