Форум Кургана и Курганской области и наших друзей

Зима. Форум Кургана и Курганской области и наших друзей
24 Октябрь 2020, 17:54:52 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости:
 
   Начало   Помощь Войти Регистрация  
Страниц: 1 ... 7 8 [9]   Вниз
  Печать  
Автор Тема: Вопросы по 1С  (Прочитано 9156 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #120 : 23 Декабрь 2011, 17:01:05 »

Код:
Процедура Сформировать()
НачатьТранзакцию();
БИ   = СоздатьОБъект("БухгалтерскиеИтоги");
    Опер = СоздатьОБъект("Операция");

БИ.ВключатьСубсчета(-1,);
БИ.ИспользоватьСубконто(); //(1е субконто счета)
БИ.ИспользоватьСубконто(); //(2е субконто счета)
БИ.ИспользоватьСубконто(); //(3е субконто счета)
БИ.ВыполнитьЗапрос(НачДата,КонДата,,,,1,,5);

БИ.ВыбратьСчета();


Пока БИ.ПолучитьСчет()=1 Цикл

БИ.ВыбратьСубконто(1);
Опер.Новая();
Опер.ДатаОперации = КонДата;

     
Пока БИ.ПолучитьСубконто(1)=1 Цикл
//Опер.НоваяПроводка();
Если БИ.Счет.Забалансовый = 0 Тогда
// Если БИ.СКД(1)<>0 Тогда
// Опер.Дебет.Счет    = БИ.Счет; 
// Опер.Дебет.Субконто(1,БИ.Субконто(1));
// Опер.Дебет.Субконто(2,БИ.Субконто(2));
// Опер.Дебет.Субконто(3,БИ.Субконто(3));
// Опер.Кредит.Счет = СчетПоКоду("00");               
// Опер.Количество = БИ.СКД(3);
// Опер.Сумма = БИ.СКД(1);
// Иначе 
// Опер.Дебет.Счет    = СчетПоКоду("00");
// Опер.Кредит.Счет = БИ.Счет;
// Опер.Кредит.Субконто(1,БИ.Субконто(1));
// Опер.Кредит.Субконто(2,БИ.Субконто(2));
// Опер.Кредит.Субконто(3,БИ.Субконто(3));
// Опер.Количество = БИ.СКК(3);
// Опер.Сумма = БИ.СКК(1);
// КонецЕсли;
// Опер.Записать();             
        Сообщить("   "+БИ.Счет+" "+БИ.Субконто(1)+"   "+БИ.Субконто(2)+"  "+БИ.Субконто(3)+" СНД  "+БИ.СНД(1)+" СКД "+БИ.СКД(1)+"  "+БИ.СКД(3)+"  "+БИ.СНК(1)+"  "+БИ.СКК(1)+"  "+БИ.СКК(3)+"  "+БИ.ДО(1)+"  "+БИ.КО(1));
Иначе               
    Прервать;

КонецЕсли;


КонецЦикла;
КонецЦикла;
ЗафиксироватьТранзакцию();
КонецПроцедуры
Вот пример кода.

Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #121 : 29 Декабрь 2011, 11:06:30 »

Ну во первых

Код:
// Опер.Записать();  


от это выноси за рамки цикла, Операцию записывать один раз. Если будешь каждую проводку записывать то это будет очень долго!!!

Во вторых вот это

Код:
БИ.Опции(0, 1);

0 - Отключили забалансовые
1 - Включили оборотные субконто, (которые как раз на девяностых)
« Последнее редактирование: 29 Декабрь 2011, 11:16:19 от M@XX » Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #122 : 13 Январь 2012, 16:44:18 »

Извините за глупые вопросы.
Но мой алгоритм не выводит итоги в разрезе субконто по счетам 50.1 , 20, 84.1.
M@XX в алгоритм внёс изменения из замечаний, без изменений.
Детализация по субконто у этих счетов появляется только когда я выбираю период. Если ставлю не период, субконто нет, есть только итоги по счёту
Подскажите ... либо я что то делаю не так, либо вводить итоги по этим счетам операцией нужно во время получения итогов по счету.
БИ.ВыбратьСчета().
Пока БИ.ПолучитьСчет()=1 Цикл
    Если (БИ.Счет = СчетПоКоду("84.1")) или (БИ.Счет = СчетПоКоду("50.1")) и т.д Тогда
        Опер.Новая();
        ...
        ...
   КонецЕсли;
КонецЦикла;
« Последнее редактирование: 14 Январь 2012, 00:35:57 от Vertex » Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #123 : 28 Январь 2012, 12:49:27 »

А они есть итоги то вообще
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
fredben
Коллежский регистратор


Карма: 0
Offline Offline

Сообщений: 2


Награды
« Ответ #124 : 06 Июнь 2012, 15:27:03 »

Хочу научиться программированию на 1с.
Записан
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #125 : 05 Октябрь 2012, 17:15:19 »

1С 7.7 ТиС
Возникли теоретические вопросы:
На что влияет флаг в документе Реализация розница флаг  "Облагается ЕНВД"? На что он влияет в рамках конфигурации?
Чем отличается документ Реализация розница и Реализация розница(ЕНВД)
и документ Продажи по принятой выручке.

Справочники > Фирмы > [закладка] Учетная политика > Налоговый учет товаров [<Разделять опт и розницу>|<Не разделять опт и розницу>]
Что меняется?
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #126 : 11 Октябрь 2012, 14:53:03 »

Налоги меняються,
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #127 : 22 Октябрь 2012, 11:16:05 »

Налоги меняються,
Пробежав визуально по коду не нашёл на что влияет флаг "ЕНВД", кроме как изменение шапки документа.
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #128 : 22 Октябрь 2012, 17:09:38 »

Пробежав визуально по коду не нашёл на что влияет флаг "ЕНВД", кроме как изменение шапки документа.
По всему глобальному модулю пробежал?  Шокирован

Если чесно с 7.7 уже как минимум год не стачивался. И как минимум 4 с ТиС

Перелезь уже на 8 ку!!!
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #129 : 26 Октябрь 2012, 17:56:56 »

По всему глобальному модулю пробежал?  Шокирован

Если чесно с 7.7 уже как минимум год не стачивался. И как минимум 4 с ТиС

Перелезь уже на 8 ку!!!
зы. Сильно трудно?
Долго осваивал?
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #130 : 29 Октябрь 2012, 11:09:12 »

зы. Сильно трудно?
Долго осваивал?
2 недели - С целью ознакомится со всеми объектами.

А так там В принципе тоже самое. Главное сначала отличия познать, если что срочное надо программировать.
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Страниц: 1 ... 7 8 [9]   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2008, Simple Machines LLC
rss | wap
Valid XHTML 1.0! Valid CSS!