Форум Кургана и Курганской области и наших друзей

Зима. Форум Кургана и Курганской области и наших друзей
24 Октябрь 2020, 15:33:46 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости:
 
   Начало   Помощь Войти Регистрация  
Страниц: 1 ... 6 7 [8] 9   Вниз
  Печать  
Автор Тема: Вопросы по 1С  (Прочитано 9153 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #105 : 01 Ноябрь 2011, 17:35:06 »

1С 7.7 Конфа всё та же  ТиС ,
провожу документы обработкой в цикле с помощью метода Док.Провести(0);
В модуле формы документа имеется процедура ПриЗаписи(), она то и не срабатывает.
« Последнее редактирование: 01 Ноябрь 2011, 17:40:19 от Vertex » Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #106 : 06 Ноябрь 2011, 11:41:25 »

1С 7.7 Конфа всё та же  ТиС ,
провожу документы обработкой в цикле с помощью метода Док.Провести(0);
В модуле формы документа имеется процедура ПриЗаписи(), она то и не срабатывает.

Решил проблему то?
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #107 : 06 Ноябрь 2011, 12:59:03 »

Цитировать
Решил проблему то?
Строит глазки Неа
Не было времени.
Да и честно говоря незнаю как решить(((? Либо писать свою процедуру создания партий либо всё же проводить в ручную. Грустный
M@XX если имеется опыт или какие либо мысли по решению данной ситуации, по возможности прошу поделиться.
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #108 : 07 Ноябрь 2011, 18:48:29 »

Короче

В твоей обработке Я так понимаю ты делаешь так.

ДокК = СоздатьОбъект("Документ.Какойто");

ДокК.Реквизит = "Что то тут";
... Ну и тут он заполняеться...
...

ДокК.Записать(); // вот тут док записался но Предопределенная процедура "ПриЗаписии()" не отработала.
ДокК.Провести(); // Провел но партии не создались.

Теперь рассмотрим эту процедуру. ("ПриЗаписи").
В это процедуре наверняка есть вызовы каких либо глобальных процедур.
Пример: СоздатьПартиПоДокументу(Контекст);

Дак вот перед Док.Провести() тебе надо выполнить вызовы этих процедур.



ДокК.Записать();

СоздатьПартиПоДокументу(ДокК.ТекущийДокумент());

ДокК.Провести();


Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #109 : 29 Ноябрь 2011, 22:05:33 »

Доброго времени.
Всё написал, партии в справочнике исправно создаются, но
когда заходишь в справочник номенклатуры > Остатки > Партии в наличии , то в поле поставщик пусто....
Так же когда выбираешь партию ручками в документе (например Реализация или Перемещение) остаток партии не показывается. Когда перепроводишь в ручную всё становится как надо.
Что куда смотреть дальше?
код расположенный в модуле документа выполняется нормально, соответственно данные попадают в регистр.
Подскажите... Засыпаю, хочу кофе
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #110 : 30 Ноябрь 2011, 16:54:54 »

Учись пользоваться отладчиком!!! Смотри что срабатывает при ручном проведении а что при программном

И будет тебе СЧАСТЬЕ!!!

Ну и как бы подробнее ситуацию описывай. Со скринами можно для наглядности
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #111 : 06 Декабрь 2011, 11:51:09 »

Проблема решена.
У создаваемого документа не был заполнен реквизит "Партия".
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #112 : 13 Декабрь 2011, 14:56:30 »

Доброго времени.
Торговлю успешно обрезал, всё нормально.
Вопрос по бухучету.
1С 7.7 Бухучет. Штатная обработка не устраивает по той же причине, что очень долго подготавливать и очень долго будет идти.
Может есть готовые обработки? Или подскажите алгоритм. Что бы не накосячить.
Заранее спасибо.
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #113 : 14 Декабрь 2011, 10:49:42 »

Набросал алгоритм вывода итогов по аналитике в разрезе субконто

Код:
БИ.ВключатьСубсчета(1,);
БИ.ИспользоватьСубконто(); //(1е субконто счета)
БИ.ИспользоватьСубконто(); //(2е субконто счета)
БИ.ИспользоватьСубконто(); //(3е субконто счета)
БИ.ВыполнитьЗапрос(НачДата,КонДата,,,,1,,5);

Если БИ.ВыбратьСчета()=0 Тогда
СтатусВозврата(0);
КонецЕсли;

Пока БИ.ПолучитьСчет()=1 Цикл
  БИ.ВыбратьСубконто(1);
Пока БИ.ПолучитьСубконто(1)=1 Цикл     
Если БИ.Счет.ЭтоГруппа()=0 Тогда
Сообщить("   "+БИ.Счет+" "+БИ.Субконто(1)+"   "+БИ.Субконто(2)+"  "+БИ.Субконто(3)+"  "+БИ.СКД(1)+"  "+БИ.СКК(1));
КонецЕсли;
КонецЦикла;
КонецЦикла;
Есть какие-либо замечания?
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #114 : 15 Декабрь 2011, 10:32:35 »

Вот это никчему:

Код:
Если БИ.ВыбратьСчета()=0 Тогда
СтатусВозврата(0);
КонецЕсли;

Сразу вот так вот делай.
Код:
БИ.ВыбратьСчета();
Пока БИ.ПолучитьСчет()=1 Цикл


Нету в выборке ничего она сама никуда не пойдет.

Вот это если лишнее
Код:
Если БИ.Счет.ЭтоГруппа()=0 Тогда

Вот тут надо просто в параметрах запроса установить что не надо выводить итоги по счетам группам.

Код:
БИ.ВключатьСубсчета(-1,);

"Минус Одын"
« Последнее редактирование: 15 Декабрь 2011, 10:38:36 от M@XX » Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #115 : 15 Декабрь 2011, 14:28:21 »

А то что пустое субконто    это не является грубым нарушением? Просто мне один товарищ сказал что оно не должно быть пустым.

       
Код:
БИ.ИспользоватьСубконто(); //(1е субконто счета)
БИ.ИспользоватьСубконто(); //(2е субконто счета)
БИ.ИспользоватьСубконто(); //(3е субконто счета)

Хотя всё работает
    Сч   Номенклатура      Субконто1            Дт Сумма Кол    Кт     
   10.3 Бензин А-80(76)   Основной склад    23547.68  1100  0  0
   10.3 Бензин АИ-92   Основной склад    758538.12  30564.58  0  0
   10.3 Бензин Премиум-А-95   Основной склад    49206.02  1880  0  0
   10.3 Газ   Основной склад    79330  3430  0  0
   10.3 Дизильное топливо   Основной склад    2641808.42  114066  0  0
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #116 : 22 Декабрь 2011, 20:32:52 »

Доброго времени.
Не могу получить итоги по девяностым счетам. (
В оборотке они есть, а обработке не у всех есть остатки и по аналитике тоже сальдо нет((
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #117 : 23 Декабрь 2011, 12:50:44 »

Печально...
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Vertex
Коллежский секретарь
****

Карма: 12
Offline Offline

у пользователя 1 предупреждение
Пол: Мужской
Сообщений: 373



Награды
« Ответ #118 : 23 Декабрь 2011, 13:48:07 »

M@XX
Поидее они должны точно так же получаться? Или их как то по особеному извлекать нужно?
Записан

Когда мужчине плохо - он ищет женщин. Когда мужчине хорошо - его ищут женщины
M@XX
burn let it all burn...
Действительный статский советник
********

Карма: 226
Offline Offline

Пол: Мужской
Сообщений: 4696


90027_veteran.gif 46859_medal1.gif

Your Buny Wrote


WWW Награды
« Ответ #119 : 23 Декабрь 2011, 16:48:59 »

Я не телепат, я же незнаю как это точно также.

Если ты конкретнопо 90 му счету получаешь итоги то и указывай конкретно по каким разрезам тебе надо.

ну и периоб запроса долже вписыватья с тандартный период, либу временный расчет запустить необходимо
Записан

1С: Предприятие. Доступно и всерьез!
ЧЕРЕЗМЕРНОЕ УПОТРЕБЛЕНИЕ ПИВА ВРЕДИТ ВАШЕМУ ЗДОРОВЬЮ
Страниц: 1 ... 6 7 [8] 9   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2008, Simple Machines LLC
rss | wap
Valid XHTML 1.0! Valid CSS!